Phone Service Interruption
Incident Report for SMRT Systems
Resolved
This incident has been resolved.
Posted Mar 28, 2022 - 08:43 PDT
Identified
We are working with our telephone company and hope to have this issue resolved shortly. Please use our email ticketing for support.
Posted Mar 28, 2022 - 08:27 PDT
This incident affected: SMRT POS (POS).