Payment failing for some requests
Incident Report for SMRT Systems
Resolved
This incident has been resolved.
Posted Oct 21, 2019 - 05:50 PDT
Identified
Our payment provider Mercury is currently experiencing issues
Posted Oct 21, 2019 - 04:58 PDT
This incident affected: Payments (Vantiv Credit Card Processing).